BTC withdrawals are now processing normally. All withdrawal requests that were delayed have been released and are being sent to the network; no funds were lost and no action is needed from your side. Deposits, withdrawals in other currencies and all other services were unaffected throughout.
Resolved
BTC withdrawals are now processing normally. All withdrawal requests that were delayed have been released and are being sent to the network; no funds were lost and no action is needed from your side. Deposits, withdrawals in other currencies and all other services were unaffected throughout.
Identified
We've identified the cause of the delays affecting Bitcoin (BTC) withdrawals and are working to restore normal processing.
Investigating
We are currently investigating an issue causing delays in Bitcoin (BTC) withdrawals. Affected withdrawal requests are safely queued, no funds have been lost and will be processed once the issue is resolved. Withdrawals in all other currencies are operating normally. Deposits, trading, and account access are unaffected. We are actively working on a fix and will post updates as we make progress.