During a scheduled migration of our custody provider, preparatory checks flagged an issue on our side.
As a precautionary measure, we temporarily restricted withdrawals to limit any impact on users.
Withdrawals are now fully restored and operating normally.
Resolved
During a scheduled migration of our custody provider, preparatory checks flagged an issue on our side.
As a precautionary measure, we temporarily restricted withdrawals to limit any impact on users.
Withdrawals are now fully restored and operating normally.
Monitoring
Withdrawal functionality has been fully restored.
Our team continues to monitor the system to ensure stable operation.
Investigating
We've identified a problem affecting withdrawals and have paused them as a precaution. Your funds are safe. We'll post an update as soon as we have more information.