Resolved
All delayed on-chain operations are processed.
Monitoring
We're observing recovery of delayed on-chain operations.
Investigating
We're investigating delay of on-chain operations
Monitoring
The system issues have been resolved and operations have returned to normal.
The team is continuing to update information as it becomes available.
Investigating
Investigating elevated block propagation and synchronization delays on blockchain nodes.