Resolved
We confirmed network congestion on the custody provider's side, which caused the disruption. The incident was escalated to the provider and has now been fully resolved.
Services are operating normally.
Investigating
We identified a transaction backlog on the withdrawal blockchain node that is currently affecting withdrawal processing. Team is investigating the issue.