Resolved
All transactions have been processed. Any intermittent deposit discrepancies are expected to self-resolve automatically.
Monitoring
Ongoing transaction has started to recover.
Team is actively investigating the issue.
Investigating
We're currently experiencing delays with some deposits and withdrawals due to an issue with one of our third-party infrastructure providers.
Transactions are not lost and will be processed once the issue is resolved.
We're actively monitoring the situation and will post updates here.