Resolved
The issue affecting Simple Earn reward distribution has been resolved. Cycle 763 completed with an approximate 30-minute delay, and all rewards have been credited. The service is operating normally.
Investigating
We are aware of a delay in Simple Earn reward distribution for the latest cycle. Balances and deposits are unaffected, and rewards will be credited once processing completes. We are actively investigating and will share an update shortly.