GoMining Status Page

Support centerSubscribe to updates
Powered by
Privacy policy

·

Terms of service
Miner Wars: Cycle 145 Retrospective
Resolved·Degraded performance

The team has reviewed the information regarding the Miner Wars Cycle 145 rewards and has provided updated reward details. For more information, please refer to GoMining's official channels.

- Official website: GoMining Official Website
- Telegram Community: GoMining Telegram Community
- Discord Server: GoMining Community
- Support email: GoMining Support (support@gomining.com)

Thu, Jun 4, 2026, 11:42 PM
(3 weeks ago)
·
Affected components
Jun 3, 2026, 05:38 PM
Jun 4, 2026, 11:42 PM
Updates

Resolved

The team has reviewed the information regarding the Miner Wars Cycle 145 rewards and has provided updated reward details. For more information, please refer to GoMining's official channels.

- Official website: GoMining Official Website
- Telegram Community: GoMining Telegram Community
- Discord Server: GoMining Community
- Support email: GoMining Support (support@gomining.com)

Thu, Jun 4, 2026, 11:42 PM

Monitoring

The team has completed the review of Miner Wars 145 Cycle Rewards. A comprehensive overview is currently being prepared.

Thu, Jun 4, 2026, 04:38 PM(7 hours earlier)

Investigating

The team has received complaints regarding Miner Wars reward calculations. A shadow-copy recalculation process has been initiated to verify reward accuracy and ensure consistency across all participants.

Wed, Jun 3, 2026, 05:38 PM(23 hours earlier)