Resolved
Miner Wars rewards have been fully distributed. The incident overview is in progress.
Monitoring
Miner Wars Rewards started to distribute.
Monitoring
Miner Wars calculation is complete. Verifying the final result before distribution.
Investigating
We’re investigating delays in personal and clan game reward calculations. All rewards will be calculated and credited in full, only processing time is affected.