Resolved
The issue was resolved.
Monitoring
We're observing restoration of email delivery.
Identified
We have identitifed root cause within a third-party service we use to send emails.
Investigating
We are currently investigating reports regarding issues with email delivery. Some users may experience delays or may not receive emails from GoMining, including notifications, confirmations, and security-related messages. Our team is actively looking into the root cause. We will provide updates as more information becomes available.