On May 13, 2026, BTC Loans experienced a period of degraded performance affecting some users. The issue was promptly identified and resolved by our engineering team. We apologize for any disruption and remain committed to providing a reliable service.
No components marked as affected
Resolved
On May 13, 2026, BTC Loans experienced a period of degraded performance affecting some users. The issue was promptly identified and resolved by our engineering team. We apologize for any disruption and remain committed to providing a reliable service.
Investigating
We are investigating reports of degraded performance affecting BTC Loans features. We will provide updates as soon as more information is available.