Resolved
We identified and resolved the issue.
Investigating
We are currently observing elevated API response times across our services. Our engineering team is actively investigating the root cause. We will provide updates as more information becomes available.