Resolved
All components are online and operating normally.
Monitoring
Incoming traffic has been rerouted. The latency spike has subsided, and processing has returned to normal.
Investigating
The team has detected increased latency on the main API Gateway and is currently investigating the issue.