Resolved
The Miner Wars rewards distribution has been successfully completed.
All eligible users should now see their updated balances reflected in their wallets.
Monitoring
Miner Wars Rewards Recalculation has completed.
Ready for distribution.
Monitoring
All withdrawals related to maintenance have been successfully returned.
The system is now prepared for Miner Wars recalculation.
Monitoring
On 07.04.2026, the team identified an inconsistency in BTC rewards distribution. The issue was caused by a disruption during the reward calculation process at 10:23 UTC.
To ensure data integrity, the team will perform a full recalculation of rewards for Cycle 137 (07.04.2026), including recomputing maintenance expenses and final reward allocations.
Monitoring
Rewards Calculation on 08.04.2026 have been completed.
Monitoring
Solo Mining Rewards have been calculated and started to distribute.
Monitoring
The team has identified a delay in the reward calculation for April 7, 2026.
The estimated time for resolution is 23:00 UTC.