Resolved
MINEBOX TON has been successfully linked to the minted wallets.
Affected users may log in to the GoMining Mobile Application or visit GoMining Website app.gomining.com.
Identified
MINEBOX TON collection is starting synchronization on GoMining platform.
Investigating
Team detected pending activation for MINEBOX TON collection on GoMining platform.
GoMining x GetGems VOL.3 Launchpad