Resolved
We're observing system latency stabilisation within operational levels.
Monitoring
We have applied a fix to resolve the issue and actively monitoring system performance.
Identified
We have identified the root cause of the elevated latency and are actively working on a fix. Our engineering team is implementing a resolution. We will provide further updates as the situation progresses.
Investigating
We are currenty experiencing elevated latency across our services. Our team has been alerted and is actively investigating the root cause. We will provide further updates as soon as more information becomes available.