The backlog of pending transactions has been fully processed, and payment processing times have returned to normal levels. Purchased Digital Miners are now being provisioned as expected.
All system components are operating within normal parameters, and no further delays are observed.
Resolved
The backlog of pending transactions has been fully processed, and payment processing times have returned to normal levels. Purchased Digital Miners are now being provisioned as expected.
All system components are operating within normal parameters, and no further delays are observed.
Investigating
We are currently experiencing delays in payment processing. Transactions are being accepted but are taking longer than usual to be confirmed and reflected in user accounts.