Write-up published
Resolved
Delayed operations have been processed.
All withdrawal are completed.
Monitoring
No withdrawals delays have been detected at this time. We are continuing to monitor the situation.
Investigating
The blockchain provider is experiencing delays in EVM network broadcasting. Withdrawals on EVM networks may be delayed.
Ref: https://status.fireblocks.com/incidents/fd5fdmk7szlh