Resolved
The Simple Earn reward distribution has completed.
Monitoring
Simple Earn Cycle 290 cycle reward distribution has started
Monitoring
Due to an issue with Miner Wars, Simple Earn reward distribution was delayed.
The accrual process has now been resumed.